+- +-
Say hello if visiting :) by Mike
23 Apr 2021, 08:55:37 am

Seti is down again by Mike
09 Aug 2017, 10:02:44 am

Some considerations regarding OpenCL MultiBeam app tuning from algorithm view by Raistmer
11 Dec 2016, 06:30:56 am

Loading APU to the limit: performance considerations by Mike
05 Nov 2016, 06:49:26 am

Better sleep on Windows - new round by Raistmer
26 Aug 2016, 02:02:31 pm

Author Topic: More trouble with X/K/Ubuntu 9.04 64bit  (Read 6671 times)

Offline Urs Echternacht

  • Volunteer Developer
  • Knight who says 'Ni!'
  • *****
  • Posts: 4121
  • ++
More trouble with X/K/Ubuntu 9.04 64bit
« on: 03 May 2009, 10:35:01 am »
Looks like others have some Tribbles with Jaunty Jackalope and opt. MB AKv8 x64 SSSE3x Build 46/47 PGO

Name   07fe09aa.24575.21749.15.8.2_0
Workunit   438668091
Created   1 May 2009 23:06:02 UTC
Sent   2 May 2009 4:36:41 UTC
Received   3 May 2009 14:13:32 UTC
Server state   Over
Outcome   Client error
Client state   Compute error
Exit status   131 (0x83)
Computer ID   4593585
Report deadline   25 May 2009 0:10:27 UTC
CPU time   2950.788412
stderr out   

<core_client_version>6.4.5</core_client_version>
<![CDATA[
<message>
process exited with code 131 (0x83, -125)
</message>
<stderr_txt>
Linux optimized S@H Enhanced application by Alex Kan
Version info: SSSE3x (Intel, Core 2-optimized v8-nographics) V5.13 by Alex Kan
SSSE3x Linux64 Build 46 PGO, Ported by : Jason G, Raistmer, JDWhale

Processor Information:
  Model: Intel Core 2 Quad Q6600, 2.97 GHz
  Package: 4 Cores

Processor Caches:
  L1 code cache, 32 KB
  L1 data cache, 32 KB
  L2 combined cache, 4 MB

Processor Features:   64bit   simd   [x86]   cmov   mmx   sse   sse2   sse3   ssse3   vmx   lm   lahf_lm   tm   tm2   eist   nx

Work Unit Info:
...............
Credit multiplier is :  2.85
WU true angle range is :  0.448236
terminate called after throwing an instance of 'std::bad_alloc'
  what():  St9bad_alloc
SIGABRT: abort calledStack trace (18 frames):
AK_V8_linux64_ssse3(boinc_catch_signal+0x17d)[0x43b70d]
/lib/libpthread.so.0[0x7fa389ed6080]
/lib/libc.so.6(gsignal+0x35)[0x7fa389b87fb5]
/lib/libc.so.6(abort+0x183)[0x7fa389b89bc3]
AK_V8_linux64_ssse3[0x576234]
AK_V8_linux64_ssse3[0x56a706]
AK_V8_linux64_ssse3[0x56a733]
AK_V8_linux64_ssse3[0x56cafa]
AK_V8_linux64_ssse3[0x56c539]
AK_V8_linux64_ssse3[0x5cf0df]
AK_V8_linux64_ssse3[0x5bd1c5]
AK_V8_linux64_ssse3[0x419d0a]
AK_V8_linux64_ssse3[0x415950]
AK_V8_linux64_ssse3[0x4149a2]
AK_V8_linux64_ssse3[0x405f7a]
AK_V8_linux64_ssse3[0x405612]
/lib/libc.so.6(__libc_start_main+0xe6)[0x7fa389b735a6]
AK_V8_linux64_ssse3(realloc+0x181)[0x405379]

Exiting...

</stderr_txt>
]]>

Validate state   Invalid
Claimed credit   38.7802458050881
Granted credit   0
application version   5.28
« Last Edit: 03 May 2009, 11:24:32 am by Urs Echternacht »
_\|/_
U r s

Offline michael37

  • Knight o' The Round Table
  • ***
  • Posts: 137
Re: More trouble with X/K/Ubuntu 9.04 64bit
« Reply #1 on: 03 May 2009, 01:40:24 pm »
(Repost from http://lunatics.kwsn.net/linux/64-bit-sse2-app.15.html)


<core_client_version>6.4.5</core_client_version>
<![CDATA[
<message>
process exited with code 131 (0x83, -125)
</message>
<stderr_txt>
Linux optimized S@H Enhanced application by Alex Kan
Version info: SSE3 (AMD/Intel, Core 2-optimized v8-nographics) V5.13 by Alex Kan
SSE3 Linux64 Build 46 PGO, Ported by : Jason G, Raistmer, JDWhale

Processor Information:
  Model: Intel Core 2 T5300, 1.73 GHz
  Package: 2 Cores

Processor Caches:
  L1 code cache, 32 KB
  L1 data cache, 32 KB
  L2 combined cache, 2 MB

Processor Features:   64bit   simd   [x86]   cmov   mmx   sse   sse2   sse3   ssse3   lm   lahf_lm   tm   tm2   eist   nx

Work Unit Info:
...............
Credit multiplier is :  2.85
WU true angle range is :  0.415339
terminate called after throwing an instance of 'std::bad_alloc'
  what():  St9bad_alloc
SIGABRT: abort calledStack trace (18 frames):
AK_V8_linux64_sse3(boinc_catch_signal+0x17d)[0x4358ed]
/lib/libpthread.so.0[0x7f564ea6f080]
/lib/libc.so.6(gsignal+0x35)[0x7f564e720fb5]
/lib/libc.so.6(abort+0x183)[0x7f564e722bc3]
AK_V8_linux64_sse3[0x570c64]
AK_V8_linux64_sse3[0x565136]
AK_V8_linux64_sse3[0x565163]
AK_V8_linux64_sse3[0x56752a]
AK_V8_linux64_sse3[0x566f69]
AK_V8_linux64_sse3[0x590d47]
AK_V8_linux64_sse3[0x58e86b]
AK_V8_linux64_sse3[0x418fce]
AK_V8_linux64_sse3[0x4159cb]
AK_V8_linux64_sse3[0x414a14]
AK_V8_linux64_sse3[0x406074]
AK_V8_linux64_sse3[0x405612]
/lib/libc.so.6(__libc_start_main+0xe6)[0x7f564e70c5a6]
AK_V8_linux64_sse3(realloc+0x181)[0x405379]

Exiting...

</stderr_txt>
]]>


Offline michael37

  • Knight o' The Round Table
  • ***
  • Posts: 137
Re: More trouble with X/K/Ubuntu 9.04 64bit
« Reply #2 on: 03 May 2009, 01:41:10 pm »
I'll be glad to file bugs on Jaunty for Ubuntu developers.  Any idea what's going wrong there?

Offline michael37

  • Knight o' The Round Table
  • ***
  • Posts: 137
Re: More trouble with X/K/Ubuntu 9.04 64bit
« Reply #3 on: 03 May 2009, 02:00:33 pm »
Opened a launchpad bug
https://bugs.launchpad.net/ubuntu/+source/boinc-app-seti/+bug/371337

I hint there that the problem is in libpthread since this library is prominently featured in all stack traces.  It would be nice to be more specific and more direct.

Offline Urs Echternacht

  • Volunteer Developer
  • Knight who says 'Ni!'
  • *****
  • Posts: 4121
  • ++
Re: More trouble with X/K/Ubuntu 9.04 64bit
« Reply #4 on: 03 May 2009, 02:02:45 pm »
I was able to reproduce the error on Kubuntu9.04amd64 liveCD version with kernel 2.6.28-11-generic (same as Ubuntu 9.04 and Xubuntu 9.04 are using). On 8 attempts (4xssse3, 4xsse3) i had it once run into this error (test0_lx64sse3), see attached files. state.sah tells something about 80% done when the error occurred.

Can't set up shared mem: -1
Linux optimized S@H Enhanced application by Alex Kan
Version info: SSE3 (AMD/Intel, Core 2-optimized v8-nographics) V5.13 by Alex Kan
SSE3 Linux64 Build 46 PGO, Ported by : Jason G, Raistmer, JDWhale

Processor Information:
  Model: Intel Core 2 T7200, 2.00 GHz
  Package: 2 Cores

Processor Caches:
  L1 code cache, 32 KB
  L1 data cache, 32 KB
  L2 combined cache, 4 MB

Processor Features:   64bit   simd   [x86]   cmov   mmx   sse   sse2   sse3   ssse3   vmx   lm   lahf_lm   tm   tm2   eist   nx

Work Unit Info:
...............
Credit multiplier is :  2.85
WU true angle range is :  0.008955
terminate called after throwing an instance of 'std::bad_alloc'
  what():  St9bad_alloc
SIGABRT: abort calledStack trace (18 frames):
./AK_V8_linux64_sse3(boinc_catch_signal+0x17d)[0x4358ed]
/lib/libpthread.so.0[0x7f7923389080]
/lib/libc.so.6(gsignal+0x35)[0x7f792303afb5]
/lib/libc.so.6(abort+0x183)[0x7f792303cbc3]
./AK_V8_linux64_sse3[0x570c64]
./AK_V8_linux64_sse3[0x565136]
./AK_V8_linux64_sse3[0x565163]
./AK_V8_linux64_sse3[0x56752a]
./AK_V8_linux64_sse3[0x566f69]
./AK_V8_linux64_sse3[0x590d47]
./AK_V8_linux64_sse3[0x58e86b]
./AK_V8_linux64_sse3[0x418fce]
./AK_V8_linux64_sse3[0x4159cb]
./AK_V8_linux64_sse3[0x414a14]
./AK_V8_linux64_sse3[0x406074]
./AK_V8_linux64_sse3[0x405612]
/lib/libc.so.6(__libc_start_main+0xe6)[0x7f79230265a6]
./AK_V8_linux64_sse3(realloc+0x181)[0x405379]

Exiting...


[attachment deleted by admin]
_\|/_
U r s

Offline Urs Echternacht

  • Volunteer Developer
  • Knight who says 'Ni!'
  • *****
  • Posts: 4121
  • ++
Re: More trouble with X/K/Ubuntu 9.04 64bit
« Reply #5 on: 03 May 2009, 02:10:28 pm »
Opened a launchpad bug
https://bugs.launchpad.net/ubuntu/+source/boinc-app-seti/+bug/371337

I hint there that the problem is in libpthread since this library is prominently featured in all stack traces.  It would be nice to be more specific and more direct.
Could you modify the bug report a bit so it gets clearer that there are different 64bit applications in different 64bit versions are failing to work ?
i.e. optimized astropulse was not seen to fail on other than "Merom" cores, but optimized seti@home seems to fail on other Core 2 cpu's as well.
« Last Edit: 03 May 2009, 02:15:02 pm by Urs Echternacht »
_\|/_
U r s

Offline michael37

  • Knight o' The Round Table
  • ***
  • Posts: 137
Re: More trouble with X/K/Ubuntu 9.04 64bit
« Reply #6 on: 03 May 2009, 09:37:56 pm »
Could you modify the bug report a bit so it gets clearer that there are different 64bit applications in different 64bit versions are failing to work ?
i.e. optimized astropulse was not seen to fail on other than "Merom" cores, but optimized seti@home seems to fail on other Core 2 cpu's as well.
We know that neither every mb workunit nor every ap workunit fails with optimized application.  Are we sure there isn't a workunit that fails on non-Merom Core 2 Duos?  I don't want to mislead the developers.



Offline Urs Echternacht

  • Volunteer Developer
  • Knight who says 'Ni!'
  • *****
  • Posts: 4121
  • ++
Re: More trouble with X/K/Ubuntu 9.04 64bit
« Reply #7 on: 05 May 2009, 07:45:18 am »
Could you modify the bug report a bit so it gets clearer that there are different 64bit applications in different 64bit versions are failing to work ?
i.e. optimized astropulse was not seen to fail on other than "Merom" cores, but optimized seti@home seems to fail on other Core 2 cpu's as well.
We know that neither every mb workunit nor every ap workunit fails with optimized application.  Are we sure there isn't a workunit that fails on non-Merom Core 2 Duos?  I don't want to mislead the developers.
Of course, up until the new reports by DeMus, jwalton and others in the seti@home Numbercrunching section (thread now moved to Questions&Answers:Unix/Linux section), there were only your reports and my repros of the problem. It seems now much more wide spread than a few days ago. But that is good for purposes of interpreting where the problem could be found and it is definitly not the cpu's. Tthe combination OS/application is producing this problem. As there were none of these problems reported before the release of Jaunty Jackalope the application (as is) is o.k., the culprit has come with the OS update.

edit: @michael37 Just saw you updated bug reports with some more info.
« Last Edit: 05 May 2009, 07:56:02 am by Urs Echternacht »
_\|/_
U r s

Offline Jason G

  • Construction Fraggle
  • Knight who says 'Ni!'
  • *****
  • Posts: 8980
Re: More trouble with X/K/Ubuntu 9.04 64bit
« Reply #8 on: 05 May 2009, 07:59:17 am »
...As there were none of these problems reported before the release of Jaunty Jackalope the application (as is) is o.k., the culprit has come with the OS update.

Just to report, I was having a conversation with a gentleman yesterday at school, who runs multiple flavours of Linux, under vmWare Vm's hosted under 64 bit Fedora.  It seems the same Ubuntu flavours are also having issues in that weird environment, that is without even running Seti@Home applications.  He seemed to be of the opinion that there was some ongoing issue with the particular kernel build involved, though I don't know enough about it myself to gauge if there's relevance here to this problem.

Jason

 

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?
Members
Total Members: 97
Latest: ToeBee
New This Month: 0
New This Week: 0
New Today: 0
Stats
Total Posts: 59558
Total Topics: 1672
Most Online Today: 19
Most Online Ever: 983
(20 Jan 2020, 03:17:55 pm)
Users Online
Members: 0
Guests: 42
Total: 42
Powered by EzPortal