+- +-
Seti is down again by Mike
09 Aug 2017, 10:02:44 am

Some considerations regarding OpenCL MultiBeam app tuning from algorithm view by Raistmer
11 Dec 2016, 06:30:56 am

Loading APU to the limit: performance considerations by Mike
05 Nov 2016, 06:49:26 am

Better sleep on Windows - new round by Raistmer
26 Aug 2016, 02:02:31 pm

MB/AP Bench Test Instruction by William
17 Jun 2016, 04:13:45 am

Author Topic: 64-bit SSE2 app?  (Read 9181 times)

Offline Urs Echternacht

  • Volunteer Developer
  • Knight who says 'Ni!'
  • *****
  • Posts: 4121
  • ++
Re: 64-bit SSE2 app?
« Reply #15 on: 01 May 2009, 06:21:54 pm »
So, if you want to use an optimized application version with kernel 2.6.28+ please use opt. astropulse 5.03 x64 sse2 application version, because astropulse x64 sse3 is not working reliable with this linux kernel.
After some more testing it is time to specialize the above warning to the necessary minimum :

So, if you want to use the optimized application version astropulse 5.03 x64 sse3 with Ubuntu/Kubuntu/Xubuntu 9.04 and kernel 2.6.28-11-generic on a core 2 mobile with "Merom" core, please use astropulse 5.03 x64 sse2 optimized application version instead.

More testing has to be done to find a better solution for this problem.
« Last Edit: 01 May 2009, 06:25:04 pm by Urs Echternacht »
_\|/_
U r s

Offline michael37

  • Knight o' The Round Table
  • ***
  • Posts: 137
Re: 64-bit SSE2 app?
« Reply #16 on: 03 May 2009, 10:24:34 am »
Urs, have you tried SSE3 MB application on your computer?   Looks like it might have the same type of the problem.

<core_client_version>6.4.5</core_client_version>
<![CDATA[
<message>
process exited with code 131 (0x83, -125)
</message>
<stderr_txt>
Linux optimized S@H Enhanced application by Alex Kan
Version info: SSE3 (AMD/Intel, Core 2-optimized v8-nographics) V5.13 by Alex Kan
SSE3 Linux64 Build 46 PGO, Ported by : Jason G, Raistmer, JDWhale

Processor Information:
  Model: Intel Core 2 T5300, 1.73 GHz
  Package: 2 Cores

Processor Caches:
  L1 code cache, 32 KB
  L1 data cache, 32 KB
  L2 combined cache, 2 MB

Processor Features:   64bit   simd   [x86]   cmov   mmx   sse   sse2   sse3   ssse3   lm   lahf_lm   tm   tm2   eist   nx

Work Unit Info:
...............
Credit multiplier is :  2.85
WU true angle range is :  0.415339
terminate called after throwing an instance of 'std::bad_alloc'
  what():  St9bad_alloc
SIGABRT: abort calledStack trace (18 frames):
AK_V8_linux64_sse3(boinc_catch_signal+0x17d)[0x4358ed]
/lib/libpthread.so.0[0x7f564ea6f080]
/lib/libc.so.6(gsignal+0x35)[0x7f564e720fb5]
/lib/libc.so.6(abort+0x183)[0x7f564e722bc3]
AK_V8_linux64_sse3[0x570c64]
AK_V8_linux64_sse3[0x565136]
AK_V8_linux64_sse3[0x565163]
AK_V8_linux64_sse3[0x56752a]
AK_V8_linux64_sse3[0x566f69]
AK_V8_linux64_sse3[0x590d47]
AK_V8_linux64_sse3[0x58e86b]
AK_V8_linux64_sse3[0x418fce]
AK_V8_linux64_sse3[0x4159cb]
AK_V8_linux64_sse3[0x414a14]
AK_V8_linux64_sse3[0x406074]
AK_V8_linux64_sse3[0x405612]
/lib/libc.so.6(__libc_start_main+0xe6)[0x7f564e70c5a6]
AK_V8_linux64_sse3(realloc+0x181)[0x405379]

Exiting...

</stderr_txt>
]]>

Offline Urs Echternacht

  • Volunteer Developer
  • Knight who says 'Ni!'
  • *****
  • Posts: 4121
  • ++
Re: 64-bit SSE2 app?
« Reply #17 on: 03 May 2009, 10:37:05 am »
Check the new thread, its another application. First guess : Ubuntu release Jaunty Jackalope has a problem !
_\|/_
U r s

jwalton

  • Guest
Re: 64-bit SSE2 app?
« Reply #18 on: 03 May 2009, 11:43:09 pm »
I, too, have started experiencing work unit errors with optimized astropulse when I upgraded to Jaunty. In my case almost every work unit failed (a few, say, ~10% finish successfully). Several examples:
Astropulse optimized SSE3:
http://setiathome.berkeley.edu/result.php?resultid=1212229070
http://setiathome.berkeley.edu/result.php?resultid=1213176158
http://setiathome.berkeley.edu/result.php?resultid=1213195971
http://setiathome.berkeley.edu/result.php?resultid=1213358495

Even Astropulse optimized SSE2 failed:
http://setiathome.berkeley.edu/result.php?resultid=1214211418
http://setiathome.berkeley.edu/result.php?resultid=1214221551

This is a on a Yorkfield core (Intel Core Quad Q9300). Here is a link to the machine: http://setiathome.berkeley.edu/show_host_detail.php?hostid=4600336

Note: The optimized MB SSE3 and SSE2 suffer the same fate as optimized astropulse on my system.

Other possibly relevant information:
Einstein@Home is the only other project running on this machine
VMware Server 2.0.1 is used to run a Windows XP guest
This was rock solid under Ubuntu 8.10 (i.e. never experienced a single work unit error).
I tried both BOINC 6.2.15 and 6.6.20 to see if it made any difference, but it did not.

 

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?
Members
Total Members: 97
Latest: ToeBee
New This Month: 0
New This Week: 0
New Today: 0
Stats
Total Posts: 59551
Total Topics: 1671
Most Online Today: 113
Most Online Ever: 402
(15 Nov 2018, 02:33:34 pm)
Users Online
Members: 0
Guests: 78
Total: 78
Powered by EzPortal