+- +-
Say hello if visiting :) by Gecko
11 Jan 2023, 07:43:05 pm

Seti is down again by Mike
09 Aug 2017, 10:02:44 am

Some considerations regarding OpenCL MultiBeam app tuning from algorithm view by Raistmer
11 Dec 2016, 06:30:56 am

Loading APU to the limit: performance considerations by Mike
05 Nov 2016, 06:49:26 am

Better sleep on Windows - new round by Raistmer
26 Aug 2016, 02:02:31 pm

Author Topic: New 2.4 app starts at nice -10 ??  (Read 4457 times)

speedy67

  • Guest
New 2.4 app starts at nice -10 ??
« on: 15 Aug 2007, 01:36:15 pm »
Hi all,

First of all thanks to all who contribute in making these wonderful optimized apps available.

A while ago, after upgrading to the 2.2B app, I (and several others) noticed that the science app no longer started at the lowest priority (nice 19) but at normal priority (nice 0). A little inconvenient in most situations, but nothing a cron job can't handle.

Just now, after upgrading to the 2.4 app on two of my Linux boxes, the system speed slowed down to a crawl and I noticed the newest science app was running at very high priority (nice -10).

Any suggestions about how this is possible, and if there is anything I can do about it besides letting cron renice the science app to lowest priority every minute?

Box1: Athlon643000+ / Ubuntu 5.10 kernel 2.6.12 / Boinc 5.2.13 / 2.4_Linux32_kernel_2.6_AMD_SSE2

Box2: P4 1.70GHz / Ubuntu 6.06LTS kernel 2.6.15 / Boinc 5.8.16 / 2.4_Linux32_kernel_2.6_Intel_SSE2

Greetings,
Sander


Offline Crunch3r

  • Knight who says 'Ni!'
  • *****
  • Posts: 602
    • 64 bit boinc clients
Re: New 2.4 app starts at nice -10 ??
« Reply #1 on: 15 Aug 2007, 02:01:37 pm »
Hi all,

First of all thanks to all who contribute in making these wonderful optimized apps available.

A while ago, after upgrading to the 2.2B app, I (and several others) noticed that the science app no longer started at the lowest priority (nice 19) but at normal priority (nice 0). A little inconvenient in most situations, but nothing a cron job can't handle.

Just now, after upgrading to the 2.4 app on two of my Linux boxes, the system speed slowed down to a crawl and I noticed the newest science app was running at very high priority (nice -10).

Any suggestions about how this is possible, and if there is anything I can do about it besides letting cron renice the science app to lowest priority every minute?

Box1: Athlon643000+ / Ubuntu 5.10 kernel 2.6.12 / Boinc 5.2.13 / 2.4_Linux32_kernel_2.6_AMD_SSE2

Box2: P4 1.70GHz / Ubuntu 6.06LTS kernel 2.6.15 / Boinc 5.8.16 / 2.4_Linux32_kernel_2.6_Intel_SSE2

Greetings,
Sander



Try using the 2.4 Kernel app. That would fix it.
I want to share something with you: The three little sentences that will get you through life. Number 1: Cover for me. Number 2: Oh, good idea, Boss! Number 3: It was like that when I got here.

Homer Simpson

speedy67

  • Guest
Re: New 2.4 app starts at nice -10 ??
« Reply #2 on: 15 Aug 2007, 02:14:40 pm »

Just now, after upgrading to the 2.4 app on two of my Linux boxes, the system speed slowed down to a crawl and I noticed the newest science app was running at very high priority (nice -10).


Try using the 2.4 Kernel app. That would fix it.


Thanks... it seems to be starting at nice 19 now. Are there any significant other differences between the apps for 2.4 and 2.6 kernel (for instance is one faster than the other?  ;D )

Greetings,
Sander

 

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?
Members
Total Members: 97
Latest: ToeBee
New This Month: 0
New This Week: 0
New Today: 0
Stats
Total Posts: 59559
Total Topics: 1672
Most Online Today: 21
Most Online Ever: 983
(20 Jan 2020, 03:17:55 pm)
Users Online
Members: 0
Guests: 25
Total: 25
Powered by EzPortal