+- +-
Say hello if visiting :) by Mike
23 Apr 2021, 08:55:37 am

Seti is down again by Mike
09 Aug 2017, 10:02:44 am

Some considerations regarding OpenCL MultiBeam app tuning from algorithm view by Raistmer
11 Dec 2016, 06:30:56 am

Loading APU to the limit: performance considerations by Mike
05 Nov 2016, 06:49:26 am

Better sleep on Windows - new round by Raistmer
26 Aug 2016, 02:02:31 pm

Author Topic: Need Network Help with openSuse 10.2 to see host with BOINCview  (Read 5067 times)

Offline Fivestar Crashtest

  • Knight o' The Realm
  • **
  • Posts: 77
I got openSuse 10.2 installed on my Pentium D and it's nice because the Boinc manager works with it.  But I can't get BOINCview to see this computer now.

With Ubuntu, I would set my BOINC folder to share and then Ubuntu would say "you need to start a samba server" or some such and I'd say ok, and as long as I had edited my gui_rpc_auth.cfg file and added the remote_hosts.cfg file, then I could see the host in BOINCview. 

I'm not figuring out how to get Suse to play nice on the network.  When I look at my workgroup I see this host as Samba (hostname).  My network places shows it as "unspecified" boinc on Samba, and not as a folder like the others. I can't get into it because it wants a password, and my root password for that host isn't working.  I set the BOINC folder to share and put all the permissions in for reading and writing. 

I tried calling the host Samba in Boincview, and putting in the ip address instead of the hostname, but that didn't work, either.

I've been googling this but maybe I just don't know enough about networking to know what to look up.  I just know I coulg make it go with Ubuntu and I can't with Suse.

Pam
All your base are belong to us!  You have no chance to survive, make your time!

Offline Simon

  • Ni!
  • Knight who says 'Ni!'
  • *****
  • Posts: 1045
    • Is it a bird? Is it a plane? No...its-the.net!
Re: Need Network Help with openSuse 10.2 to see host with BOINCview
« Reply #1 on: 14 May 2007, 03:25:03 pm »
/etc/init.d/SuSeFirewallsetup start/stop  (don't crucify me for mis-capitalization, blame SuSe, Suse, Susie or whoever - I remember when it was DLD...good old times ;)).

I'd recommend just disabling the firewall, not really necessary on a dedicated cruncher unless it's exposed to the net.

HTH,
Simon.

Offline Fivestar Crashtest

  • Knight o' The Realm
  • **
  • Posts: 77
Re: Need Network Help with openSuse 10.2 to see host with BOINCview
« Reply #2 on: 15 May 2007, 11:29:00 pm »
Thanks for the hint, Simon.  I didn't have that exact named directory and I couldn't do much with it when I found it, but I fumbled around some more and now I can see this host in BOINCview.

I guess I had thought I'd dealt with the firewall.  I asked to open ports for both Samba and Windows Domain Membership using Yast.  This time I went straight to the firewall in Yast which was under "Security", and managed to get it stopped. 

I have a host with Windows XP 64 Pro eval that will expire next week.  If I can get Suse installed on it, I will try to get the firewall disabled during the installation.  I have a router that is firewalled, so I hope that's good enough.
All your base are belong to us!  You have no chance to survive, make your time!

Offline Simon

  • Ni!
  • Knight who says 'Ni!'
  • *****
  • Posts: 1045
    • Is it a bird? Is it a plane? No...its-the.net!
Re: Need Network Help with openSuse 10.2 to see host with BOINCview
« Reply #3 on: 15 May 2007, 11:58:47 pm »
Hi Pam,

BOINCview (like the manager itself when you do remote control) needs an open port so it'll work. I forgot the exact port, should be on the (unofficial?) wiki somewhere, or maybe someone else can chime in on that.

Still, having a firewalling router should be enough for a dedicated cruncher, so you can safely disable the firewall anyway.

I'm pretty rusty on Suse, so I may have got the path wrong. Anyway, Google said /etc/sysconfig/SuSEfirewall2 is the config file for the firewall, and that it's well documented. Hope so ;)

Regards,
Simon.

Offline Purple Rabbit

  • Squire
  • *
  • Posts: 38
Re: Need Network Help with openSuse 10.2 to see host with BOINCview
« Reply #4 on: 17 May 2007, 10:43:17 am »
I'm running both Suse 10.1 and 10.2 on several of my machines. BOINCView is working for all of them. The default Samba configuration under 10.2 is different than under 10.1. I can't speak to what Ubantu does. I had to play around changing preferences to get file sharing to work for 10.2. That said:

Samba isn't needed with the recent releases (past year or so) of BOICView. The old method of reading state files has been removed in favor of TCP connections. The needed open port is the same as BOINC Manager (31416).

Because I go through this drill every time I make a new install (my memory ain't what it was) I'll list a few questions as ideas to consider. Usually the answer to one of these solved my problem.

Can you see the host using BOINC Manager on the host that is running BOINCView?
Did you put the correct password in BOINCView for the host?
Is the list of allowed hosts in remote_hosts.cfg correct?
Have you tried using the IP address instead of the host name in BOINCView?
Are you using compatible BOINCView and BOINC versions?
Are you using the "funky" password BOINC generates (unique to each host) or did you change it to something you can remember? (I gave all my hosts the same, easy to remember password)

No need to reply to each question (unless you have a question :)). I'm just trying to brainstorm ideas. I'm sure it's something simple, but it's always something hard until you stumble on the "easy" solution ;)

Rick
« Last Edit: 17 May 2007, 11:15:23 am by Purple Rabbit »

Offline Fivestar Crashtest

  • Knight o' The Realm
  • **
  • Posts: 77
Re: Need Network Help with openSuse 10.2 to see host with BOINCview
« Reply #5 on: 18 May 2007, 11:57:24 pm »
I got my openSuse installation on my Xeon3220 up and showing in BOINCview pretty fast tonight.  I disabled the firewall during the installation.  I put the remote hosts config file in the BOINC folder and changed the password on the remote gui rpc cfg file.  I went into SAMBA through Yast and set the boinc folder to share.  I went upstairs and looked at BOINCView and it wasn't showing yet.

I went into the Windows Domain Membership in Yast and it said I needed some libraries for Samba and clicked ok to download them and when that was done, went back upstairs and -voila!- there it was.

Here's hoping that host will keep getting work.
All your base are belong to us!  You have no chance to survive, make your time!

 

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?
Members
Total Members: 97
Latest: ToeBee
New This Month: 0
New This Week: 0
New Today: 0
Stats
Total Posts: 59558
Total Topics: 1672
Most Online Today: 19
Most Online Ever: 983
(20 Jan 2020, 03:17:55 pm)
Users Online
Members: 0
Guests: 46
Total: 46
Powered by EzPortal