+- +-
Say hello if visiting :) by Gecko
11 Jan 2023, 07:43:05 pm

Seti is down again by Mike
09 Aug 2017, 10:02:44 am

Some considerations regarding OpenCL MultiBeam app tuning from algorithm view by Raistmer
11 Dec 2016, 06:30:56 am

Loading APU to the limit: performance considerations by Mike
05 Nov 2016, 06:49:26 am

Better sleep on Windows - new round by Raistmer
26 Aug 2016, 02:02:31 pm

Author Topic: Core 2 app working on non-Core 2 CPU?  (Read 5033 times)

Offline michael37

  • Knight o' The Round Table
  • ***
  • Posts: 137
Core 2 app working on non-Core 2 CPU?
« on: 30 Jun 2007, 12:40:24 am »
Quick question to expert community.  I got hands on a quad-Dempsey.  Nice system with HT enabled, makes up 8 processors.  It's marketed as Intel 50XX family of processors, and it's a last family preceding Core 2-based Woodcrests (aka 51xx family).  It's definitely not a Core 2.

So, I tried running the SSSE3 app and it completed the test workunit faster than any other app.  Then, I ran iit for a few days and it had no problems running nor validating workunits.

Am I missing something?  Isn't Core 2 app supposed to break on non Core-2 CPUs?  I am running

Optimized SETI@Home Enhanced application
Optimizers: Ben Herndon, Josef Segur, Alex Kan, Simon Zadra
Linux port: Crunch3r, Hans Dorn, Simon Zadra
   Version: Linux 64-bit based on S@H V5.15  'Noo? No - Ni!'
  Revision: R-2.2B|xT|FFT:IPP_SSSE3|Ben-Joe
     CPUID:                   Intel(R) Xeon(TM) CPU 3.40GHz
      CPUs: 2, cores: 1,  cache: L1=16K,  L2=1024K, L3=16384K
  Features: MMX  SSE  SSE2  SSE3  SSSE3 x86_64


If anyone wants to look, here is link to this host. 

Offline Simon

  • Ni!
  • Knight who says 'Ni!'
  • *****
  • Posts: 1045
    • Is it a bird? Is it a plane? No...its-the.net!
Re: Core 2 app working on non-Core 2 CPU?
« Reply #1 on: 30 Jun 2007, 01:13:35 am »
Hm,

until now I thought there was only one ill-fated - and never commercially released - pre-Core 2 CPU that supported SSSE3, and that's the "Tejas". PD-descendant, large caches, slightly better power consumption than 9xx PDs, but no match for Opterons at the time.

So either Intel decided to market them as 50xx and I missed that, or something strange is going on :)

Regards,
Simon.

Offline michael37

  • Knight o' The Round Table
  • ***
  • Posts: 137
Re: Core 2 app working on non-Core 2 CPU?
« Reply #2 on: 30 Jun 2007, 11:26:05 am »
It's strange indeed.  Notably, and expectedly, the higher clock speed (3.4GHz) Dempsey based on Netburst technology performs slower than my Core 2 Woodcrest at 2.66GHz.    At 8 CPUs though, the total RAC is not bad.

I wish I had some quad cores for apples to apples 8-way comparison.

 

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?
Members
Total Members: 97
Latest: ToeBee
New This Month: 0
New This Week: 0
New Today: 0
Stats
Total Posts: 59559
Total Topics: 1672
Most Online Today: 19
Most Online Ever: 983
(20 Jan 2020, 03:17:55 pm)
Users Online
Members: 0
Guests: 10
Total: 10
Powered by EzPortal