+- +-
Seti is down again by Mike
09 Aug 2017, 10:02:44 am

Some considerations regarding OpenCL MultiBeam app tuning from algorithm view by Raistmer
11 Dec 2016, 06:30:56 am

Loading APU to the limit: performance considerations by Mike
05 Nov 2016, 06:49:26 am

Better sleep on Windows - new round by Raistmer
26 Aug 2016, 02:02:31 pm

MB/AP Bench Test Instruction by William
17 Jun 2016, 04:13:45 am

Author Topic: Status of these boards  (Read 17043 times)

Offline ToeBee

  • Janitor o' the Board
  • Squire
  • *****
  • Posts: 20
Status of these boards
« on: 26 Oct 2015, 02:09:48 am »
You may have noticed that there was an outage of these boards a few days ago. I fixed it eventually but I actually have no idea what exactly fixed it. It was showing a PHP error. The error is because the server is running a newer version of PHP than this forum software was designed to run on. But the this error is actually being thrown constantly in the background so I don't know why it suddenly caused an outage.

However this highlighted the fact that this forum is running really, really old software. I know there have been problems with posts being blank. I have no idea why that is happening and I don't see any errors in the logs. I suspect it is another PHP version problem. While trying to fix the outage I looked into upgrading to the newest version of SMF. I actually performed the upgrade and you can see the rather poor results at http://test.lunatics.kwsn.info/.

First of all you will notice that the custom theme is completely broken. That can probably be fixed with some effort. The bigger problem is that the upgrade disabled all extensions. This reset the site back to being nothing but a forum. The front page with the download links and news feed is all gone. That functionality is supplied by an extension named Enigma and this extension is no longer maintained. There might be newer extensions available now that provide similar functionality but I'm not sure.

Is anyone else around here by chance familiar with the SFM software or have any other ideas for how to get this site running on a more modern system?
« Last Edit: 26 Oct 2015, 02:18:18 am by ToeBee »

Offline ToeBee

  • Janitor o' the Board
  • Squire
  • *****
  • Posts: 20
Re: Status of these boards
« Reply #1 on: 26 Oct 2015, 02:28:11 am »
And in making the above post I actually ran into the blank post problem. Wow, that is indeed weird.  In this case it seems to have gone away when I removed a double space in the middle of the post. But I can't replicate the problem now by intentionally using a double space. Sooo... I have no clue what's going on there.

Offline arkayn

  • Janitor o' the Board
  • Knight who says 'Ni!'
  • *****
  • Posts: 1230
  • Aaaarrrrgggghhhh
    • My Little Place On The Internet
Re: Status of these boards
« Reply #2 on: 26 Oct 2015, 07:02:29 pm »
I would be the person who is most familiar with SMF as I run the Sister site for this place at Crunchers Anonymous

I am running SMF 2.0.11 and Tiny Portal over there, which has a built in download manager.

There is also EZ Portal. I recommend Download System for use with that.

EzPortal is the only one that has been updated to work with the upcoming 2.1 release of SMF.

Offline arkayn

  • Janitor o' the Board
  • Knight who says 'Ni!'
  • *****
  • Posts: 1230
  • Aaaarrrrgggghhhh
    • My Little Place On The Internet
Re: Status of these boards
« Reply #3 on: 26 Oct 2015, 11:44:08 pm »
Of course the theme is not compatible either.

Offline ToeBee

  • Janitor o' the Board
  • Squire
  • *****
  • Posts: 20
Re: Status of these boards
« Reply #4 on: 27 Oct 2015, 12:56:08 am »
Thank you for your suggestions. I've been tinkering with them tonight. As you pointed out the custom theme is totally broken so I just completely disabled it. Other than that I've managed to replicate a fair bit of the functionality of the current setup... I think. Definitely not a finished product and I'm guessing I will need to redo it all anyway once it is decided to do the upgrade for real. But please go look and let me know what you think. http://test.lunatics.kwsn.net

Offline arkayn

  • Janitor o' the Board
  • Knight who says 'Ni!'
  • *****
  • Posts: 1230
  • Aaaarrrrgggghhhh
    • My Little Place On The Internet
Re: Status of these boards
« Reply #5 on: 27 Oct 2015, 06:13:23 pm »
Thank you for your suggestions. I've been tinkering with them tonight. As you pointed out the custom theme is totally broken so I just completely disabled it. Other than that I've managed to replicate a fair bit of the functionality of the current setup... I think. Definitely not a finished product and I'm guessing I will need to redo it all anyway once it is decided to do the upgrade for real. But please go look and let me know what you think. http://test.lunatics.kwsn.info

Fixed the link...

Offline Raistmer

  • Working Code Wizard
  • Volunteer Developer
  • Knight who says 'Ni!'
  • *****
  • Posts: 14342
Re: Status of these boards
« Reply #6 on: 28 Oct 2015, 04:32:48 am »
What was very useful place for SETI-related cooperation/development recently became pain in the *ss actually.
My posts longer than 1-2 strings disappear. And now I'm always on 13-th page (of 16) in "New ways of signals logging" thread. Please do smth with boards software or at least I will be forced to abandon this site despite of all sorry about this that I feel.

Offline arkayn

  • Janitor o' the Board
  • Knight who says 'Ni!'
  • *****
  • Posts: 1230
  • Aaaarrrrgggghhhh
    • My Little Place On The Internet
Re: Status of these boards
« Reply #7 on: 28 Oct 2015, 10:38:58 am »
The test site is running just fine as SMF 2.0.11 works great with the current version of mysql.

Offline Raistmer

  • Working Code Wizard
  • Volunteer Developer
  • Knight who says 'Ni!'
  • *****
  • Posts: 14342
Re: Status of these boards
« Reply #8 on: 28 Oct 2015, 12:18:00 pm »
The test site is running just fine as SMF 2.0.11 works great with the current version of mysql.
Where it resides? Cause very this board still lose posts!

Offline arkayn

  • Janitor o' the Board
  • Knight who says 'Ni!'
  • *****
  • Posts: 1230
  • Aaaarrrrgggghhhh
    • My Little Place On The Internet
Re: Status of these boards
« Reply #9 on: 28 Oct 2015, 12:28:15 pm »
The test site is running just fine as SMF 2.0.11 works great with the current version of mysql.
Where it resides? Cause very this board still lose posts!


http://test.lunatics.kwsn.info/

Offline ToeBee

  • Janitor o' the Board
  • Squire
  • *****
  • Posts: 20
Re: Status of these boards
« Reply #10 on: 28 Oct 2015, 04:20:19 pm »
Just don't use the test site for anything "real" yet. It is a clone I took last weekend so it is missing new posts and such so I will need to wipe it out and start over after I figure a few more things out.

Offline Raistmer

  • Working Code Wizard
  • Volunteer Developer
  • Knight who says 'Ni!'
  • *****
  • Posts: 14342
Re: Status of these boards
« Reply #11 on: 28 Oct 2015, 05:51:09 pm »
Just don't use the test site for anything "real" yet. It is a clone I took last weekend so it is missing new posts and such so I will need to wipe it out and start over after I figure a few more things out.
Heh, this site missing new posts too :/

Offline ToeBee

  • Janitor o' the Board
  • Squire
  • *****
  • Posts: 20
Re: Status of these boards
« Reply #12 on: 28 Oct 2015, 11:45:37 pm »
Just don't use the test site for anything "real" yet. It is a clone I took last weekend so it is missing new posts and such so I will need to wipe it out and start over after I figure a few more things out.
Heh, this site missing new posts too :/

Only ones made here on the old site after I cloned the database.

Offline ToeBee

  • Janitor o' the Board
  • Squire
  • *****
  • Posts: 20
Re: Status of these boards
« Reply #13 on: 29 Oct 2015, 12:50:26 am »
Wow, people. This vanishing post problem is terrible. Anyway, it looks like Josef hasn't been around for a while. I feel like it would be good to get his input on this change

Offline arkayn

  • Janitor o' the Board
  • Knight who says 'Ni!'
  • *****
  • Posts: 1230
  • Aaaarrrrgggghhhh
    • My Little Place On The Internet
Re: Status of these boards
« Reply #14 on: 29 Oct 2015, 01:33:08 am »
Wow, people. This vanishing post problem is terrible. Anyway, it looks like Josef hasn't been around for a while. I feel like it would be good to get his input on this change

We would like to know if he okay as he has not posted anywhere since August, and his computers have also not connected to SETI either.

 

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?
Members
Total Members: 97
Latest: ToeBee
New This Month: 0
New This Week: 0
New Today: 0
Stats
Total Posts: 59540
Total Topics: 1671
Most Online Today: 16
Most Online Ever: 272
(16 Dec 2008, 08:23:07 pm)
Users Online
Members: 0
Guests: 11
Total: 11
Powered by EzPortal