Forum > Linux

SIGSEGV Error on new BOINC Install


Terror Australis:
I'm having problems with a new Linux BOINC install. Whenever I run it, it crashes with a SIGSEGV error.

OS is a basic Mageia 1 x64, on a clean install

Starting it from a console using the --v option I get 3 errors before it crashes they are...
catalog file for domain 'wxstd' not found

catalog file for domain 'wxgtk' not found

catalog file for domain 'BOINC Manager' not found

After doing a search I found that wxgtk was not installed so I downloaded and installed lib64wxgtk2.8 from the  Mageia repository - no Joy

Looking at the verbose report it looked like there could be a path problem due to the fact I had installed using Australian English so I changed that to US_en - It found BOINC Manager but still missed wxstd and wcgtk . I added paths to where wxgtk was installed and to the Locale folder in the BOINC directory - no joy

I've triple checked the permissions and set the BOINC folder to 777 to make sure that's not the problem.

Is the SIGSEGV error due to the lost files or do I have another problem as well

I'm out of ideas, can anyone help ?


1) What boinc version?
2) Do an ldd boinc and see if it finds all the libraries it wants.

-Start boinc first, boinc manager last
-Maybe these will also help:

Terror Australis:
I blew the whole lot away and started again.

After checking the links Sunu provided it's possible that this  problem is due to a bug in the 6.10.xx clients which only appears in certain flavours of Linux. Mageia and Ubuntu seem to be two of them.

I followed the method I had used before, I installed Mandriva then "upgraded" to Mageia over the top of it.

(For those that don't know Mageia is a Mandriva fork and their install DVD has the facility to upgrade over the top of a Mandriva install)

This has solved the SIGSEGV error !! (phew).

When I start BOINC with -verbose option, the other path errors are still there but they do not seem to effect the operation. A check on my other Mageia machine shows the same error messages.

I have reported the SIGSEGV bug to Magiea.



[0] Message Index

Go to full version